Menu

RechercheV : une valeur unique mais choix multiples -> VBA ? [Résolu/Fermé]

Messages postés
3
Date d'inscription
mercredi 5 mars 2014
Dernière intervention
23 avril 2014
-
Bonjour,

Depuis quelques jours je cherche, j'essaye, mais rien n'y fait. Etant un pseudo débutant sur excel et manipulant un peu VBA, j'en viens à votre aide, voilà mon problème :

..........1.............2............. 3

1.......201 .......uytu ..........50€
2 ......201 ......dzefzu ......100€
3 ......201 ........dfgdui ......8€
4...... 202 ........
5.......202... etc

J'aimerais, sommer les différente positions ayant pour référence un même numéro (colonne 1 ) dans une même cellule sur une autre feuille (ici j'aurais 201 : 158€). J'ai vraiment du mal avec les formules matricielles et par VBA j'ai essayé des boucles simple type IF THEN ELSE mais ça m'oblige à recopier toute les valeurs autres part selon un ordre spécifique selon leur positions pour pouvoir les sommer ultérieurement.

Voilà, je vous serais très reconnaissant si vous pouvez m'indiquer quelques outils VBA qui pourraient m'aider ou me mettre sur la piste, ou tout simplement m'expliquer :)

Merci d'avance

Benjamin
Afficher la suite 

1 réponse

Messages postés
7449
Date d'inscription
dimanche 13 juin 2010
Dernière intervention
16 décembre 2018
0
Merci
Une simple formule en colonne D :
=SOMME.SI($A$1:$A$5;A1;$C$1:$C$5)
à reproduire vers le bas
benjaminpierron
Messages postés
3
Date d'inscription
mercredi 5 mars 2014
Dernière intervention
23 avril 2014
-
Merci pour votre réponse, ça marche très bien

Cordialement,


Benjamin
Chap 244 | Noblesse 234 - Chapter 234 Dec 08, 2016 | 28.02.1720:48 Uhr PDF And The Acrobats - The Flying Lap Dog Pop256 kbit/s 0 / 02.152 Hits VID P2P DDL 0 Kommentare